Home | SearchFAQ You are not logged in: Register | Log In
 
Please Read:
An important message from System 7 Today founder Dan Palka
 
 Topic: MacX for X session over SSH in System 7 (Page 1 of 2)
Post ReplyGo to page 1, 2  Next
  passthejoe (Profile)
  8 MB
 
Posted: Mon Jun 30, 2008 12:26 pm
Quote
  
I've been looking everywhere for the MacX software, which allows pre-OS X Macs to run an X session over SSH from a Linux/Unix box.

I've been using MacSSH, which works great for a console session, but I'd really like to see how well I can do X in System 7.6.1.

I could be wrong, but I believe the newest version of MacX for System 7 is MacX 2.0. Older versions include 1.2 and 1.5.

As I say, I've been looking for MacX for awhile but have had no luck.
  
  wove (Profile)
  Moderator
 
Posted: Tue Jul 01, 2008 10:46 pm
Quote
  
MacX was part of A/UX and I was never aware of it as an separate application for any other MacOS.

Tenon Systems had/has a product called MachX, which did enable the X window system for the Classic Mac OS.

bill
  
  CyberMonkey (Profile)
  16 MB
 
Posted: Fri Jul 04, 2008 10:53 pm
Quote
  
You mean this one?
http://en.wikipedia.org/wiki/MacX
  
  dpaanlka (Profile)
  1024 MB
 
Posted: Sat Jul 05, 2008 12:51 am
Quote
  
I don't have page for it, but I've experimented a little with MI/X for PPC Macs, which did work, and you can download here:

http://download.system7today.com/mixppc.sit
  
  gillham (Profile)
  16 MB
 
Posted: Thu Aug 14, 2008 1:09 pm
Quote
  
MacX 1.2 (from an A/UX 3.0.1 install) launches on System 7.1 but generates a message similar to "Communications Toolbox missing".

If I put the basic connectivity set from apple.com in my System Folder it starts and says roughly "Communications Toolbox not working, will not accept connections until then".

I can get the precise error messages if someone is interested. I will also try running it on 7.6.1 in case more of the communications toolbox stuff is there and working.
  
  gillham (Profile)
  16 MB
 
Posted: Fri Aug 15, 2008 2:01 pm
Quote
  
To followup on this I will say I was dumb. Smile I realized there was a MacTCP Tool in the A/UX system folder. It works fine under 7.1 and 7.6.1

I must say MacX 1.2 isn't too bad, even on my AWS80. It worked a lot better than Mix68k. Mix is X11R6 based, but hardly worked at all on my AWS80 and was buggy. I haven't tried the PPC version yet. Also I'm using 8bit mode since that is all the onboard video supports. That might not be its best mode.

Alas I have figured out that my AWS80 didn't ship with A/UX so until I can find a real copy I can't really use this anyway. I'm glad to know it works though, hopefully I'll run into a copy of MacX for sale or even better A/UX. Smile

Oh and to address the original question of using ssh. I tried out MacSSH with the "forward X" checked and it worked ok with XFree86 libraries (on my NetBSD box), but wasn't so happy with X.org based stuff with Ubuntu on my MythTV box. Both worked fine directly connecting, but ssh tunneling didn't work at all with Ubuntu.

I'll try some of this again with a PowerMac and MixPPC at some point here.
  
Topic Tools
Post Reply

Start New Topic in this folder.
Go to page 1, 2  Next

© 2010 System7Today.com.
The Apple Logo, Macintosh™, Mac OS™, and others property of Apple Computer, Inc.
This site is in no way affiliated with Apple Computer, Inc.