Home | SearchFAQ You are not logged in: Register | Log In
 
Please Read:
An important message from System 7 Today founder Dan Palka
 
 Topic: Are you running Mac OS 7? (Page 14 of 17)
Post ReplyGo to page Previous  1, 2, 3 ... 13, 14, 15, 16, 17  Next

Do you still have a machine running Mac OS 7?
Yes - Mac OS 7.0.x
4%
 4%  [ 9 ]
Yes - Mac OS 7.1.x
6%
 6%  [ 14 ]
Yes - Mac OS 7.5.x
25%
 25%  [ 51 ]
Yes - Mac OS 7.6.x
55%
 55%  [ 113 ]
No
7%
 7%  [ 15 ]
Total Votes : 202

  Jotokun (Profile)
  2 MB
 
Posted: Fri Aug 01, 2008 9:38 am
Quote
  
My SE FDHD runs 7.1, but thats only because I cant make any boot disks to bring it down to 7.0.1. My PB 1400cs runs 7.6.1. Back wehn I had them, my LC580, LCIII and Power mac 6100 all ran 7.5.5.
  
  IronTooth (Profile)
  8 MB
 
Posted: Wed Feb 11, 2009 8:36 am
Quote
  
I recently pulled my PowerBook 1400cs/133 out of retirement to act as a 'bridge' computer when upgrading my Lady Technophobe from a Quadra 650 running 7.6.1 to an iMac G3/400 running Panther. The PowerBook 1400 has an ethernet card; I used LocalTalk to pull her Claris Emailer data off the Quadra, and then sent it to the iMac over ethernet. I had the PB1400 running Mac OS 9.1, but 'upgraded' it to System 7.6.1 for this task, and for use in its semi-retirement. I still have a 9.1 install on a CompactFlash card for those odd occasions when I might need it.

I also have an SE in inactive-but-working status that IIRC has 7.0.1 installed.

- Don
  
  defor (Profile)
  16 MB
 
Posted: Fri Nov 13, 2009 12:20 pm
Quote
  
My current list of maintained system 7 machines:

PowerBook 550c: 7.6.1
PowerBook 500 PPC Factory install: 7.6.1
PowerBook 2300c: 7.6.1
PowerBook 5300/133 Prototype Mustang: 7.6.1
Assistive Freestyle: 7.6.1
PowerBook G3/250 Kanga: 7.6.0

MacTV: 7.6.1
ClassicTV (Color Classic with MacTV IR and Motherboard): 7.6.1
PowerMac 9500/1GHz G4: 7.6.1
  
  dpaanlka (Profile)
  1024 MB
 
Posted: Fri Nov 13, 2009 2:47 pm
Quote
  
defor wrote:

PowerBook G3/250 Kanga: 7.6.0


And how did you manage that? And why only 7.6.0?
  
  defor (Profile)
  16 MB
 
Posted: Fri Nov 13, 2009 5:35 pm
Quote
  
Figured you'd ask- I actually need to finish up a blog entry detailing it and with copies of the customized install set- basically I expanded the existing pb 3400c system enabler to re-support 2400 (for which it was initially intended), and add the 3500 as well.

1) Boot the system from a modified 3400c install cd with wish i were's extension installed into the cd's system folder and with prefs set to cloak gestalt as a 3400c.

2) Install 7.6.0 as if it were a 3400c (this requires the specific 3400 install disc as a retail 7.6.0 disc doesn't have the basic drivers injected into the system file to support the hardware- the 3400c installer also MUST think it's on a 3400c or the support for the 3400 hardware- and 3500 as it's identical, won't be installed, resulting in more non-bootability.)

3) Copy the new enabler to the system folder on hdd (this is also on the cd in a tools folder)

4) Reboot off HDD - you should have 7.6.0 running and stable.

Now the problem is 7.6.1, there's a conflict with CFM 68k .. in 7.6.1 at least some bit of core code that supports it is inside the data fork to the system file (aka PPC code) ... if you remove cfm 68k altogether, it's stable, but most apps won't run- I've tried EVERY version fo the CFM extensions, and have found that the problem is with the code in the system file.

A half-ass solution was to create a hybrid system file with the data fork from 7.6.0 and the resources (aka drivers, etc) from 7.6.1- this seems stable, but a few things seem to be buggy, and I still need to see if a more legitimate solution can be found- It's going to require a modification to the system file at least to get it going, but I should be able to minimize the 7.6.0 chunks to jsut support cfm.. or so I hope...

I don't consider the installer disc complete yet, but it does provide a completely stable 7.6.0 environment via a direct install (no additional computers, scsi link, or pulling the drive).

If anyone out there knows a way to create apple installer tomes, I need major help with that! TomeViewer has let me pull out the files and I've got them modifed as needed to provide a simple single boot method, but without any way to reinject them, It won't be possible to make the disc "proper" .. it IS working as it stands however. I'll go into more detail once I finish writing this all up.
  
  dpaanlka (Profile)
  1024 MB
 
Posted: Fri Nov 13, 2009 7:16 pm
Quote
  
Hmm well you certainly have my attention. I'll be way more intrigued if/when 7.6.1 is working.

Your CFM issues probably have something to do with this:

The minor update to Mac OS 7.6.1 finally ported the 68k exception handling routines to PowerPC, turning dreaded type 11 errors into less harmful errors (type 1, 2 or 3, usually) as crashing applications would more often terminate safely instead of crashing the operating system.
  
Topic Tools
Post Reply

Start New Topic in this folder.
Go to page Previous  1, 2, 3 ... 13, 14, 15, 16, 17  Next

© 2010 System7Today.com.
The Apple Logo, Macintosh™, Mac OS™, and others property of Apple Computer, Inc.
This site is in no way affiliated with Apple Computer, Inc.